Back to overview
Downtime
Vanilla Launching and Store outage
Jun 18, 2026 at 5:26pm UTC
Affected services
Main Site
Store
Launching
Updated
Jun 18, 2026 at 7:57pm UTC
Issues with Vanilla Launching, Downloading the launcher, and accessing the Store have now been resolved. We are working on a fix for issues relating to Discord Rewards.
Affected services
Created
Jun 18, 2026 at 5:26pm UTC
We are investigating an outage affecting game launching and the store, an issue with an upstream provider is causing requests that depend on it to fail. Our team is actively working on a resolution and we will provide updates as we learn more.
Affected services