Back to overview
Degraded

Intermittent connectivity issues

Dec 09 at 11:40am EST
Affected services
Store
Metadata
Launching

Resolved
Dec 09 at 04:15pm EST

The issue has been resolved, and all users should be able to play as normal.

Updated
Dec 09 at 03:50pm EST

Roughly 60% of the impacted users are now able to connect successfully, we are still in communication with Cloudflare for a full recovery.

Created
Dec 09 at 11:40am EST

Some users are experiencing connectivity issues when trying to open the launcher or launch the game, and some store purchases may be delayed. We have determined this is caused by an incident with our provider, Cloudflare. We're in contact with Cloudflare and are working on a resolution.